I suggest you ...

Fix LiveReload to work with https

I get this error in Firefox 13 when loading the page over SSL :

The operation is insecure.
this.socket = new this.WebSocket(this._uri);

402 votes
Vote
Sign in
Check!
(thinking…)
Reset
or sign in with
  • facebook
  • google
    Password icon
    I agree to the terms of service
    Signed in as (Sign out)
    You have left! (?) (thinking…)
    Pierre Olivier MartelPierre Olivier Martel shared this idea  ·   ·  Admin →
    planned  ·  Andrey TarantsovAdminAndrey Tarantsov (Founder, LiveReload) responded  · 

    Planning to look into it some time soon.

    The main problem is that livereload.js can be accessed via multiple domain names, and even when it’s on localhost, there’s no way to obtain a trusted SSL certificate for localhost. I do have a few options in mind, though.

    27 comments

    Sign in
    Check!
    (thinking…)
    Reset
    or sign in with
    • facebook
    • google
      Password icon
      I agree to the terms of service
      Signed in as (Sign out)
      Submitting...
      • yaron.guezyaron.guez commented  · 

        I miss LiveReload! I haven't been able to use it since migrating all of my workflows to HTTPS. Hopefully this gets implemented one day.

      • FredFred commented  · 

        Any update? This is a really old post so I'm hoping there's a fix or workaround. Thanks!

      • Carlos CollartCarlos Collart commented  · 

        but...but...I have a valid (trusted) SSL on my localhost... just want the change in the chrome extension from http:// to just //

      • AlexAlex commented  · 

        Bump! This is needed.

      • OhadOhad commented  · 

        +1 how about using // in the beginning and let the user work around the certificate issue

      • HughHugh commented  · 

        Perhaps there could be a setting that we could point it to a self-signed certificate (localhost)?

        Thanks

      • Anonymous commented  · 

        definitely +1 :)
        and you're awesome, many thanks

      • Michael DealMichael Deal commented  · 

        +1 This would be a really nice addition. I have no problem setting up a self-signed SSL certificate for localhost. It seems if the script was loaded from // as Curtis mentioned, it would work? However, currently the script is not being served from port 443 in addition to port 80...

      • sj98177sj98177 commented  · 

        Hello, is there a patch yet for this? Thanks

      • Bas BloemsaatBas Bloemsaat commented  · 

        chrome stopped working too as of this week. Can I do anything to speed it up?

      • defrexdefrex commented  · 

        In case anyone is interested, I solved this problem using nginx as a proxy. I have a self-signed wildcard cert for the domain defrex.dev already installed in my browser.

        In my `nginx.conf`,

        server {
        server_name livereload.defrex.dev;
        listen 443 ssl spdy;

        ssl_certificate /home/defrex/.ssl/wld_defrex_dev.crt;
        ssl_certificate_key /home/defrex/.ssl/wld_defrex_dev.key;

        location / {
        proxy_pass http://localhost:35729;
        }
        }

        I also added this line to my `/etc/hosts` file.

        127.0.0.1 livereload.defrex.dev

        Now I can safely include this in my html,

        <script src="https://livereload.defrex.dev/livereload.js"></script>

      • mrflixmrflix commented  · 

        I recently set up a local https environment to be able to work fluidly with Webcam + Microphone input (navigator.getUserMedia). Only with https it remembers my permission (at least in Chrome).

        But now livereload doesn't work in those tabs. For now I'll go with the workaround to force Chrome to allow. In the long term it would be great to have it work out of the box.

        While researching the matter I stumbled over this config: https://github.com/gruntjs/grunt-contrib-connect/issues/70
        I'd be okay with such a configuration – e.g. to put in my path to my certs and the pass-phrases.

      ← Previous 1

      Feedback and Knowledge Base